It is currently Mon Nov 12, 2018 5:46 pm


Cutmaster 152 Problems

Thermal Dynamics plasma cutter discussion forum.
War Hammer
Posts: 7
Joined: Sun Sep 24, 2017 8:52 pm

Cutmaster 152 Problems

Postby War Hammer » Tue Apr 03, 2018 7:48 pm

Hello all,

I am still very new to this whole CNC business. Here is my current problem, my torch will randomly not shut off. When it goes from cut path to cut path in a rapid movement it continues to cut. when I push the emergency stop on the machine the torch still stays on. This is a random occurrence and doesn't happen all the time but when it does the only way to shut the torch off is to manually shut off the plasma generator.
Then when I turn the machine back on it shows an error code (75psi blinking with error blinking)according to the manual that is a "start signal error".
After cycling it several times I can get the torch back on line and it will work for a few cuts then randomly it will fault again.
I just got the plasma generator back from the repair facility they said it tested fine and they said it is not the machine but the computer program.
I have been through the entire program with the manufacture and the system checks out.
here the specs of the system:

Dynatorch 5x10 table (Old Version downdraft table)
Dynatorch software (2012 Ver.)
Thermal Dynamics 152 (Blue Professional Version)
All cut information is set as per the Thermal Dynamics cut sheet

Any help would be awesome.
Thanks everyone.

Elite Contributing Member
Elite Contributing Member
Posts: 418
Joined: Thu Jul 24, 2008 11:15 am

Re: Cutmaster 152 Problems

Postby plasmanewbie » Thu Apr 05, 2018 11:13 am

Have you tried to disconnect the plasma interface cable from the machine controller to determine if the machine controller or the plasma cutter is the issue?

War Hammer
Posts: 7
Joined: Sun Sep 24, 2017 8:52 pm

Re: Cutmaster 152 Problems

Postby War Hammer » Thu Apr 05, 2018 11:34 pm

I have not. do I do that when the machine stays on or after I reset it. I hate to sound too dumb but I am not sure how I would know by disconnecting the cable.
Would you please explain the procedure?
Thanks for reply and the help.

Brand X
Posts: 489
Joined: Wed Apr 23, 2014 2:48 pm

Re: Cutmaster 152 Problems

Postby Brand X » Fri Apr 06, 2018 12:33 pm

If your 152 has a cnc interface receptacle on the back of the machine. Disconnect, and just jump the 3/4 pins together to start the plasma torch to fire.See if the torch stays lit after you stop touching the pins together.. If your machine does not have a interface you will need to pull the cover off the 152, and figure out where the start wires are hooked up.. Pictures will help..That will let you know if it's the 152 or your control box.. Do you have a machine torch on the 152? There is a hand torch, Machine torch, and Automation torch for the Cutmaster 152..

War Hammer
Posts: 7
Joined: Sun Sep 24, 2017 8:52 pm

Re: Cutmaster 152 Problems

Postby War Hammer » Sat Apr 07, 2018 1:13 am

Thank you guys so much I will check that first thing tomorrow and I will post pictures. It does have the machine torch on it although I do have a hand torch.
I will jump the wires in the morning and see what happens.
Thanks again.

Posts: 1
Joined: Sun Dec 17, 2017 12:29 am

Re: Cutmaster 152 Problems

Postby Minuteman » Tue May 08, 2018 8:57 am

This just happen to me so it is fresh in my mind. I also am new to all of this. I was having a similar problem where the torch stayed on between cuts. I kept watching this post to see if a solution was ever found. As stupid as the cause of "my" problem. But also fueled by the fact that even experienced people are quick to suggest purchasing replacement parts. I decided to post what I found out in the hope that it might help someone else. In my case I was setting up a new table a Star-Lab 5 x 10 with Linux and Candcnc controls using my CutMaster 152. I purchased and installed the 9-8311 Interface. Being new to all of this I did not know what was causing the problem. I tried most of the suggestions given here and narrowed the problem down to the Plasma cutter. I contacted the manufacturer of my table to see if he ever heard of this. Matt sent a new PWM overnight and together he walked me through testing and said it was the plasma cutter. The next morning I called the TD service number and talked to a gentlemen there. He suggested that a cable needed replaced. I contacted the supplier where I purchased the Interface and gave him the information from the TD tech. I decided not to wait on the "try the cable swap" and ordered overnight another Interface kit. That did not cure my problem. More money thrown away. I spent the weekend tracing out connections and planning to try option 2 connection shown in the 152 manual. It came down to the fact that I would need a different board from Candcnc. That meant waiting until Monday anyway and the second solution seemed to me like going backwards not forward. But anything to get up and running right? Come Monday morning I decided to call TD service and see where they were at with the cable idea. My original tech was busy...I had been dealing with this for over a week. My nerves and attitude were... well testy at best. The nice lady put me in touch with a different tech. I will not give his name but he has years of experience. He asked what was happening and wanted to know what interface I was using. I told him the 9-8311 and he said that good, now go out and see what the machine is set on. He said you want the knob on the run "2 o'clock" position not the lock position. I had it in the lock position. So there it is, as Stupid as it is. Sometimes it's the simple things.
I want to thank everyone for their help and sorry War Hammer hope you are up and running! mm

Return to “Thermal Dynamics Plasma Cutters”

Who is online

Users browsing this forum: No registered users and 2 guests

Easyscriber engrave attachment for Hypertherm torch's