Torch Not Returning To "0"

Post your questions or tips on SheetCam software in this topic.
Post Reply
Blackslacks
Posts: 25
Joined: Mon Apr 16, 2018 10:16 pm

Torch Not Returning To "0"

Post by Blackslacks » Tue Mar 17, 2020 2:07 pm

Ive noticed recently that when running a drawing through the simulation mode of Sheetcam 6.0.30, torch does not return to what ever I have set in Parking options. If I set x5, y5 it will park at 4.89,4.94 or something similar. Even if I set to 0,0 it will not go there. If I uncheck the axis, it will still not go to zero. Its always off by a few thou. Ive even reinstalled the program, no difference. If I run the same drawing, same post, in the Development version it is exact. Any ideas anyone. Thanks

User avatar
acourtjester
Elite Contributing Member
Elite Contributing Member
Posts: 4225
Joined: Sat Jun 02, 2012 6:04 pm
Location: Pensacola, Fla

Re: Torch Not Returning To "0"

Post by acourtjester » Tue Mar 17, 2020 2:34 pm

I have only used the Development version for years without a problem.
DIY 4X4 Plasma/Router Table
Hypertherm PM65 Machine Torch
Drag Knife and Scribe
Miller Mig welder
13" metal lathe
Small Mill
Everlast PowerTig 255 EXT

robertspark
Elite Contributing Member
Elite Contributing Member
Posts: 649
Joined: Mon Jun 12, 2017 6:43 pm
Location: nr Liverpool, UK

Re: Torch Not Returning To "0"

Post by robertspark » Tue Mar 17, 2020 3:38 pm

Why would you not run the development version?
UCCNC,
Sheetcam
Hypertherm Powermax 45 (nonXP)
Neuron Lite THC
Hobby user (4x4 home table)

Blackslacks
Posts: 25
Joined: Mon Apr 16, 2018 10:16 pm

Re: Torch Not Returning To "0"

Post by Blackslacks » Tue Mar 17, 2020 6:33 pm

I have no problem using the development version. I usually do anyway. But I was just curious as to what would cause that issue.

User avatar
djreiswig
Elite Contributing Member
Elite Contributing Member
Posts: 798
Joined: Thu Nov 19, 2015 10:02 pm
Location: SE Nebraska

Re: Torch Not Returning To "0"

Post by djreiswig » Tue Mar 17, 2020 7:13 pm

I've tried the development version a few times, but I always seem to have issues with it so I go back to the stable version.
2014 Bulltear (StarLab) 4x8
C&CNC EtherCut
Mach3, SheetCam, Draftsight
Hypertherm PM65
Oxy/Acetylene Flame Torch
Pneumatic Plate Marker, Ohmic, 10 inch Rotary Chuck (in progress)

Les Newell
Posts: 119
Joined: Tue Mar 22, 2016 10:30 am

Re: Torch Not Returning To "0"

Post by Les Newell » Wed Mar 18, 2020 9:22 am

Blackslacks wrote:
Tue Mar 17, 2020 2:07 pm
Ive noticed recently that when running a drawing through the simulation mode of Sheetcam 6.0.30, torch does not return to what ever I have set in Parking options. If I set x5, y5 it will park at 4.89,4.94 or something similar.
Can you see these coordinates in the g-code?

Blackslacks
Posts: 25
Joined: Mon Apr 16, 2018 10:16 pm

Re: Torch Not Returning To "0"

Post by Blackslacks » Wed Mar 18, 2020 11:38 am

Here is my gcode:

N0010 (Filename: rollerbracket.tap)
N0020 (Post processor: Plasma PriceCNC AVHC10 THC zFloat With Pierce Delay- G31.scpost)
N0030 (Date: 16/03/2020)
N0040 G20 (Units: Inches)
N0050 G53 G90 G40
N0060 F1
N0070 S500
N0080 (Part: rollerbracket)
N0090 (Process: Outside Offset, 0, T2: 16 Ga 45A 124V)
N0100 M06 T2 (16 Ga 45A 124V)
N0110 G00 X1.7146 Y0.5519 Z0.3937
N0120 G31 Z -100 F19.685
N0130 G92 Z0.0
N0140 G00 Z0.1340
N0150 G92 Z0.0
N0160 G00 X1.7146 Y0.5519 Z0.1500
N0170 M03
N0180 G04 P0.1
N0190 G01 Z0.0600 F3.937
N0200 X1.7500 Y0.5165 F224.0
N0210 M10P2
N0220 G03 X1.7500 Y0.5165 I0.0000 J0.2335 F192.0
N0230 M11P2
N0240 G01 X1.7854 Y0.5519 F224.0
N0250 M05
N0260 G00 Z0.3937
N0270 X3.5543 Y1.7916
N0280 G31 Z -100 F19.685
N0290 G92 Z0.0
N0300 G00 Z0.1340
N0310 G92 Z0.0
N0320 G00 X3.5543 Y1.7916 Z0.1500
N0330 M03
N0340 G04 P0.1
N0350 G01 Z0.0600 F3.937
N0360 X3.5265 Y1.7500 F320.0
N0370 G02 X-0.0265 Y1.7500 I-1.7765 J0.0000
N0380 G01 Y5.2225
N0390 G02 X0.0000 Y5.2490 I0.0265 J0.0000
N0400 G01 X2.5000
N0410 G02 X2.5187 Y5.2412 I0.0000 J-0.0265
N0420 G01 X3.5187 Y4.2412
N0430 G02 X3.5265 Y4.2225 I-0.0187 J-0.0187
N0440 G01 Y1.7500
N0450 X3.5543 Y1.7084
N0460 M05
N0470 G00 Z0.3937
N0480 X0.0000 Y0.0000
N0490 M05 M30


After running this it parks at X .0943 y .0052
Thanks

Blackslacks
Posts: 25
Joined: Mon Apr 16, 2018 10:16 pm

Re: Torch Not Returning To "0"

Post by Blackslacks » Wed Mar 18, 2020 11:46 am

PS I realize the cut height is not right.

Les Newell
Posts: 119
Joined: Tue Mar 22, 2016 10:30 am

Re: Torch Not Returning To "0"

Post by Les Newell » Wed Mar 18, 2020 11:50 am

Looking at these lines:

Code: Select all

N0470 G00 Z0.3937
N0480 X0.0000 Y0.0000
the machine is being told to move to X0 Y0 Z0.3937. The machine can only move to the nearest step so it is fairly common for the actual position to be displayed with an error of up to +/- half a step. However you say the X is showing .0943 which seems a lot. I am not sure what is going on there.

Post Reply

Return to “SheetCam”

Industry Pros use FastCut CNC