Linux/CommandCNC - Z Loosing position during cutting

CommandCNC related questions and tips can be posted to this topic.
Post Reply
User avatar
Posts: 339
Joined: Mon Jul 06, 2015 1:57 pm
Location: Wiltshire, UK

Linux/CommandCNC - Z Loosing position during cutting

Post by exapprentice » Mon Jul 03, 2017 11:23 am


Any one come across the Z zero / cut heights on longish cuts loosing position using Linux/CommandCNC?

I have just watched my machine cut a part and during the cuts the torch would do its touch of routine on every new pierce and noticed on some cuts the torch would dive at the end of the cut, not enough for the torch to go below material top but a definite dive (I do have the VAD ticked so I am assuming that The VAD is catching the move?)

During the touch off's watching the Z DRO it does seem to zero out and go to pierce height but its hard to watch both the DRO and the torch at the same time so I cannot say what is actually going on at that point

(my assumption is that after I have homed the Z at the start of the job and the file starts it does its own home/zero routine on each new pierce? or is it using the original home routine?)

When it started the last cut (it was a longer cut than any of the others in the file) I noticed that the Z DRO starting climbing up so instead of cut height (0.5 mm) it was going up and finished at 54 mm
Now I am not sure where the increase happened as I was not on the ball at that time but I did notice the numbers increasing during the cut

My Z is pretty subdued and I do not think its a acceleration/ step issue as I learned very early on not to push these to the limit and preferred a slower more precise style rather than flat out and getting errors which has worked for me so far :o
I am not using any ohmic sensing just the Standard floating Z axis with switch off set

I would think if there was another cut after this point then the torch would have tried to go way past the top of the material into the machine
so it does seem to me it is like the Z touch of routine does not re-zero on each touch off and does rely on the original homing before the start of the file if that makes sense

anybody have any ideas on what to check or try or what might be causing this? :cry:

I will try and wait for some suggestions before cutting again and for any guidance that maybe available I think that CandCNC are on 4th July hols at the moment ;)
Best Regards to all
Exapprentice :D
10'x5' DIY table / PM 45XP + M/C Torch - Trying to add 4 axis Tube cutting :(
Linux/CommandCandCNC MP3600 / PN200 / DCP-01 / PWM
Solid Edge, Inkscape, SheetCam, Scananything & Andonstar USB Microscope

User avatar
Elite Contributing Member
Elite Contributing Member
Posts: 3554
Joined: Sat Jun 02, 2012 6:04 pm
Location: Pensacola, Fla

Re: Linux/CommandCNC - Z Loosing position during cutting

Post by acourtjester » Mon Jul 03, 2017 11:37 am

I don't have command CNC yet so this is just a logical though, with each touch off and Z set to zero it should not be looking back at your original Z zero at the start. Have you looked at the G-code where you have had the problem to see if it has the touch off commands for each cut start?
Are you able to run a G-code without the torch on to watch the cut operation (no wasting of material). I have a switch in my arc OK circuit so I can turn in on and run cut operations without the torch cutting (plasma unit is also off).
DIY 4X4 Plasma/Router Table
CandCNC DTHC-IV & Feather Touch
Hypertherm PM65 Machine Torch
Drag Knife and Scribe
Miller Mig welder
13" metal lathe
Small Mill
Everlast PM 256 tig

Posts: 1111
Joined: Tue Feb 28, 2012 6:47 pm

Re: Linux/CommandCNC - Z Loosing position during cutting

Post by tcaudle » Mon Jul 03, 2017 11:48 am

The support forum is not on holiday. Most of you assumptions are not correct. First a touch off (which is a PROBE function does NOT zero the Z it simply sets the offset in negative numbers so it knows how far to lift to do the rapid clearance. The dive at the end has to be from the torch slowing down (Velocity) and the VAD will catch it but it needs to see the % slowdown you have set before it locks.
You still have the option to use a cut rule to turn the DTHC off Before the End of the cut if it seems you cannot set the VAD to do it for you .

ALSO...the Z DRO during a cut is not a true reflection of the actual position of the Z. If you will look at the code you will see a call to a sub routine called "endofCut" where it takes the accumulated moves and settles up with the DRO. Only if you are losing steps or the Z is not moving when the motor is spining will it get out of sync. The next touch off will correct it though.

We prefer not to use PS for doing one on one support. You can use our direct email (yes its checked on weekends and holidays or the support forum that gets check several times per day.

Have you found he Disable Torch button in CommandCNC? it disables the torch and the DTHC so you can do a "air" cut . You don't even have to turn off your plasma and you don't need to fool the ARC OK since with the Disable torch its ignored

Post Reply

Return to “CommandCNC - Linux”

Easyscriber engrave attachment for Hypertherm torch's