Torch won't fire - need help troubleshooting please

CandCNC plasma table components discussion forum
Post Reply
chattacuda
Elite Contributing Member
Elite Contributing Member
Posts: 47
Joined: Fri Mar 15, 2013 11:33 am

Torch won't fire - need help troubleshooting please

Post by chattacuda » Sat Jan 09, 2021 6:05 pm

CandCNC ESPII-A electronics (Ethercut Linux + Command CNC) and Hypertherm 45XP plasma. Been working great last 2 1/2 years since upgraded to new system and plasma. Had just cut a bunch of 3/8" AR-500 and next morning put a sheet of 1/4 A-36 on table and torch would not fire. Did all the standard troubleshooting that I know how to do. Verified ground good on plate, installed new consumables, air pressure good at plasma connection, cable connections checked, etc.

Torch will fire when I jumper CPC pins 3 and 4 both at the plasma unit and at the MIC-01 cable ends (with the cable unplugged from the PWMII sensor).

When I try and fire the torch from Command CNC screen, the Torch Off icon changes to Torch On and the diagnostics screen output status shows torch output lit. Also, the DTHC card Red LED lights "HOLD". However, the DTHC to PMW module LED does not change state (stays green) and the PMWII sensor module "torch on" red LED does not light. I swapped the Cat 5 yellow cable with no change.

I am the end of my knowledge of what to do next. My gut says it may be the DTHC card but I have no idea.

I have had lightning problems give me a fit before and is the main reason I upgraded system. However I always unplug the plasma cutter and the electronics all go through a UPS. We had no storms or power blips the night before this all started.

Any help on next steps would be greatly appreciated. I really need to get this current job cut.

Thanks!
chattacuda from Dayton, Tennessee
CandCNC electronics, Precision Plasma V rail gantry, homemade 4'x8' water table, Sharpe Air Dryer
Hyperthem 45XP, CommandCNC, Sheetcam, Corel Draw

adbuch
Elite Contributing Member
Elite Contributing Member
Posts: 1491
Joined: Thu Sep 21, 2017 5:22 pm
Location: Tucson, Arizona
Contact:

Re: Torch won't fire - need help troubleshooting please

Post by adbuch » Sun Jan 10, 2021 2:18 am

It is possible you have a faulty torch control cable (cable from plasma cutter to controller).
David

chattacuda
Elite Contributing Member
Elite Contributing Member
Posts: 47
Joined: Fri Mar 15, 2013 11:33 am

Re: Torch won't fire - need help troubleshooting please

Post by chattacuda » Sun Jan 10, 2021 8:57 am

I test fired the torch through that cable after it fired from shorting pins 3 and 4 at the CPC. So unless I am missing what you are saying, I think I eliminated that. Also, I replaced the yellow CAT 5 cable between the card on the controller box and the PMWII card. Any other ideas?
chattacuda from Dayton, Tennessee
CandCNC electronics, Precision Plasma V rail gantry, homemade 4'x8' water table, Sharpe Air Dryer
Hyperthem 45XP, CommandCNC, Sheetcam, Corel Draw

chattacuda
Elite Contributing Member
Elite Contributing Member
Posts: 47
Joined: Fri Mar 15, 2013 11:33 am

Re: Torch won't fire - need help troubleshooting please

Post by chattacuda » Sun Jan 10, 2021 1:40 pm

Also, I checked the PWMII acr ok and volts cal and neither work with the cat % cable connected and the MIC-01 cable not connected. I hope it's just the PWM. Cant hear any click when test firing torch from the console either like I normally do
chattacuda from Dayton, Tennessee
CandCNC electronics, Precision Plasma V rail gantry, homemade 4'x8' water table, Sharpe Air Dryer
Hyperthem 45XP, CommandCNC, Sheetcam, Corel Draw

weldguy
Elite Contributing Member
Elite Contributing Member
Posts: 616
Joined: Fri Apr 17, 2009 11:48 am

Re: Torch won't fire - need help troubleshooting please

Post by weldguy » Mon Jan 11, 2021 12:08 pm

If you can locate the relay that you hear click when the torch fires I would look into that next. Does the relay contacts function as is should or has it gone bad? Is the relay even getting its signal to close?

chattacuda
Elite Contributing Member
Elite Contributing Member
Posts: 47
Joined: Fri Mar 15, 2013 11:33 am

Re: Torch won't fire - need help troubleshooting please

Post by chattacuda » Mon Jan 11, 2021 5:43 pm

Big thanks to David Woods from CandCNC Tech Support. Turned out to be the RS485 4 Port Hub. Apparently some high frequency noise or electrical glitch can cause them to go offline. Just a matter of unplugging it for 10 seconds then re-initiating the system. I cant say enough about the CandCNC tech support. In the 8 years or so I have used their systems and had to call on RARE occasion, they were quick to help figure it out and help get it fixed.
chattacuda from Dayton, Tennessee
CandCNC electronics, Precision Plasma V rail gantry, homemade 4'x8' water table, Sharpe Air Dryer
Hyperthem 45XP, CommandCNC, Sheetcam, Corel Draw

Post Reply

Return to “CandCNC”

Industry Pros use FastCut CNC