Page 1 of 1

Gcode Error, Help!

Posted: Tue Aug 15, 2017 12:23 pm
by morocco119
I have successfully assembled and wired a 4x4 plasma table out of raw materials but I have one issue between my CAM and machine. everytime i go to load up a file to cut it gives me this error:

"Near line 3 of
P word with no G2 G3 G4 G10 G64 G5 G5.2
g76 g82 g86 g88 g89 or M50 M51 M52 M53
M62 M63 M64 M65 M66 or user M code to use it."

My setup is as follows:
LinuxCNC 2.7 with THC-toma Configuration files (from this Forum)
AVHC10 THC From PriceCNC

Fusion 360 For Modeling set post processor to "burnytable" as it does not support EMC2 plasma postprocessing.
Tried SheetCAM Same Error message displays.
(Also linuxCNC seems to like .NGC Files)

The machine can cut well but only using manual jogging, I have learned a lot from building a table but this last portion is taunting me on how close but how far I am from running programs. Any insight is very helpful and greatly appreciated, Thank you.

Re: Gcode Error, Help!

Posted: Wed Aug 16, 2017 10:32 am
by tcaudle
EMC needs g-code in a very specific format. I doubt a Burny post will get you there. Its LinuxCNC telling you "I don't understand the code you are sending me"

You may have to consider a different CAM package than using Fusion 360 or find someone that has written a plasma post for EMC (aka Linuxcnc)

Re: Gcode Error, Help!

Posted: Fri Aug 18, 2017 12:53 pm
by morocco119
Thank you for your help,
I read through the README.txt file again and came across it saying this version of Linux didn't need any postprocessor and it ran off of inkscape to generate Gcode through a plug-in.

Ran the program on a simulated linuxCNC computer and the file had no problem opening but everything was scaled down 3.75x I am able to fix this by multiplying my dimensions on inkscape (3x3 inch part into 11.25x11.25in to make linuxCNC read 3x3) a step forward a smaller step backwards i suppose.

Re: Gcode Error, Help!

Posted: Fri Aug 18, 2017 2:26 pm
by acourtjester
Do you have both programs using inch dimensions?

Re: Gcode Error, Help!

Posted: Sat Aug 19, 2017 2:09 pm
by tcaudle
Its a plugin (extension) for inkscape and is OS independant. It looks like a cheap and usable alternative but it does not seem to have a way to do a custom POST that would include some of the special things you need for a plasma application. Things like: auto - touch-off, pierce delay, pierce height and cut height settings. So once you get the scaling problem fixed you will need to see if there is anyway to modify the Russian based app to do plasma specific code; much the same problem you have with Fusion 360.

Its open source and in Python so you could do you own mods to make it work with plasma. So far I don't see any users that have it working with plasma.
Inkscape units are in "pixtels" (screen resolution) beacuse it used SVG and that was origianlly a web based vector display format.

Re: Gcode Error, Help!

Posted: Wed Aug 23, 2017 5:09 pm
by morocco119
Yes both programs were set to inch dimensions,
For anyone else that might run into the scaling problem in the future. Inkscape version 9.2 was updated but the extensions were not updated to work with 9.2 causing scaling issues, downgrading to version 9.1 has fixed the issue.

on linuxcnc fourms it looks like some users have had it running, but it has proven to be difficult for me. The other functions mentioned above this post look to be already integrated into the LinuxCNC configuration files so it looks like everything needed for plasma cutting is there.

I will download the mach 3 trial and see how that works with my current set-up and fusion 360, hopefully I can get to cutting sooner with that software over Linux, there seems to be a majority of users here using mach 3 so support should be better if I run into any issues if at all.

I will update with my findings soon,
thank you all for your support.

Re: Gcode Error, Help!

Posted: Thu Aug 24, 2017 3:21 pm
by tcaudle
I am not sure you understand the relationship of G-code to either LINUXCNC or MACH3. If your g-code that it spits out is not correct for plasma cutting or cannot call a sub routine in LINUXCNC (If there is one) then it's not going to work. If there is a function in LINUXCNC called "touchoff" then SOMETHING in the G-code has to call the action at the right time. The problem here is not LINUXCNC (or MACH3) it's the fact you cannot get the correct POST for Fusion 360. There is a MACH post but its for router/mill. As long as you cling to using Fusion 360 for the CAM part its going to be a difficult if not impossible task . POSTS can be developed for Fusion 360 but its not straight forward. With the Russian CAM part in Inkscape there does not appear to be a way to customize the posts (output) to put in the proper code for the specail actions required for plasma.

yes a lot of users here use MACH3 but most also use SheetCAM that has MACH3 plasma posts in several flavors. Up until The a couple of years ago MACH3 was the only lower cost Windows controller with built in THC logic. SheetCAM has an open POST scripting language and there are over a hundred POSTS that you can open in a simple text editor and easily modify.

Why don't you consider the path of least resistance:

Fusion360 --> DXF --> SheetCAM --> MACH3
Inkscape --> SVG --> SheetCAM --> MACH3

While MACH3 is obsolete and its limited to WIN7 32 bit or before (for parallel port) there are thousands of copies out there and a lot of users with plasma tables.

Re: Gcode Error, Help!

Posted: Tue Aug 29, 2017 11:50 am
by Njcnc
Can you post a snippet of your Gcode as well as the sheetcam post processor you would like to use? I use that Toma Linuxcnc config exclusively and it works great for me. The post processors will be incredibly simple since the touch off, pierce height and delay are all done automatically off of a single M3 in the code.

Re: Gcode Error, Help!

Posted: Wed Sep 06, 2017 8:55 pm
by morocco119
Alright update time,
I purchased and installed Mach 3 for the Plasma table and in turn installed a custom post from Autodesk for Mach plasma and everything works smoothly as in running a program (torch probes material, backs off and fires) no Gcode errors to be found yet.

Unfortunately a new issue is that the THC will connect to Mach in the diagnostic tab via the light array but will not control the Z Axis during a test cut with the simulated outputs on. When "Torch on" is active the program moves but when "Torch up/down" is active the program stops XY movement but the Z Axis doesn't adjust.
Mach 3 is fully licensed and the THC on button is illuminated on the main screen.

As always any insight is highly appreciated,
thank you

Re: Gcode Error, Help!

Posted: Thu Sep 07, 2017 9:27 am
by acourtjester
turn off the simulated outputs, they are for if you want to test but not when operating.

Re: Gcode Error, Help!

Posted: Fri Sep 08, 2017 8:58 pm
by morocco119
You were right!
Ran a program and let the THC do its thing. Set the Z height to probe and back off 0.25" and the THC controller lit up and adjusted the Z height automatically.

The table runs pretty well, cut out a 3" circle as a test and it's 1/16 shy but a circle nonetheless, have to adjust that in my CAM settings.
Thank you all so much for your help!