It is currently Wed Dec 13, 2017 7:48 am

 

t123 torch problem, burnt wires

Hypertherm Plasma Cutter discussion forum.
i_r_machinist
Posts: 112
Joined: Mon Oct 18, 2010 3:22 pm

t123 torch problem, burnt wires

Postby i_r_machinist » Mon Nov 20, 2017 8:39 am

I upgraded my table to a 85 amp machine with the duramax mechanical cutter a while ago and kept my ht 600 to cut my drop off up with. This has been working just fine until I saw smoke comming out of the handle of the t123. I took it apart and found this.
20171119_104907.jpg

Where do the two red wires attach? What is this indicative of? I had replaced the handle cover and was wonering if I had pinched the wires on re-assembly.
Any ideas?

You do not have access to download this dxf file.
Become a Contributing Member to gain access to the thousands of files shared by our members. Click Here


jimcolt
Elite Contributing Member
Elite Contributing Member
Posts: 2768
Joined: Mon Jul 20, 2009 11:18 pm
Location: New Hampshire

Re: t123 torch problem, burnt wires

Postby jimcolt » Wed Nov 22, 2017 8:41 am

The red wires are the nozzle connection (positive DC from the power supply). Looks like something was pinched or chafed inside the handle.....likely there was full cutting power shorted between the negative lead (brass nut) and the red wires. You can get the service manual at the www.hypertherm.com website . Jim Colt Hypertherm Also, can contact tech service for help, advice: [email protected] or 1 800 643 9878

i_r_machinist
Posts: 112
Joined: Mon Oct 18, 2010 3:22 pm

Re: t123 torch problem, burnt wires

Postby i_r_machinist » Mon Nov 27, 2017 9:55 am

Thanks Jim!


Return to “Hypertherm Plasma Cutters”

Who is online

Users browsing this forum: No registered users and 2 guests