It is currently Mon Dec 18, 2017 5:24 pm

 

hypertherm powermax 1000 g3 series - fault

Hypertherm Plasma Cutter discussion forum.
jen
Posts: 9
Joined: Tue Mar 23, 2010 4:03 pm

hypertherm powermax 1000 g3 series - fault

Postby jen » Mon Jul 03, 2017 10:29 am

good morning - this is a long shot - but I turned on my Hypertherm 1000 and the red fault light was on - got the book out and from what I can tell - the air pressure light that should be green was yellow- not flashing yellow but yellow - I had not changed anything on the air pressure so I checked the air hose, it was connected, still same red fault light.
I am hoping someone would have a suggestion as to what to look for next -
thanks in advance
Jen

jimcolt
Elite Contributing Member
Elite Contributing Member
Posts: 2770
Joined: Mon Jul 20, 2009 11:18 pm
Location: New Hampshire

Re: hypertherm powermax 1000 g3 series - fault

Postby jimcolt » Tue Jul 04, 2017 8:22 am

From the service manual.....when the air pressure yellow LED is on and the red fault light is on that often indicates "stuck" consumables in the torch.

Put in new electrode, new swirl ring, new nozzle. Be sure the retaining cap is just snug, not over tightened. Install a pressure gauge (hard plumbed) right at the air inlet. Turn amperage knob fully clockwise (air will flow at torch) read inlet pressure gauge (the one you just installed), it must be between 90 and 120 psi, adjust air regulator until pressure LED's are satisfied.

If the above does not work, contact Hypertherm technical service for more troubleshooting. [email protected] or 1 800 643 9878 Jim Colt Hypertherm


Return to “Hypertherm Plasma Cutters”

Who is online

Users browsing this forum: No registered users and 1 guest